AIX Commands

AIX OS Commands:

To find the HMC IP from LPAR
/usr/sbin/rsct/bin/rmcdomainstatus -s ctrmc

To check more than 2MB files under /var
find /var/ -xdev -size +2048 -ls | sort -r

To check the processes which are used by /var filesystem
fuser -cdfxV /var

To check the RAID level of the hdisk
lsattr -El hdisk3 | grep raid

To check 15 most cpu utilized processes
ps -ef |egrep -v "STIME| $LOGNAME" |sort +3 -r| head -n 15

To find the microcode of the system
lsmcode

To check machine S.No
lsconf |grep -i machine

To find the firmware version of AIX
lscfg -vp| grep -p Platform

To check the eth media speed
entstat -d en0 |grep "Media Speed"

To check the status of Link Line
netstat -v en0 |grep -p "Specific Statistics"

To find the MAC address of the eth
netstat -ia

To find the virtual location of an ethernet adapter
lscfg -l ent1

To Check Failed Login
who -a /etc/security/failedlogin

Find the version of AIX that is running
oslevel, osleve -s

List all attributes of system
getconf -a

bootinfo and getconf can return much of the same information, getconf
returns more and has the grepable -a option.

Find the level of firmware on a system
invscout

List all attributes for the kernel \device"
lsattr -El sys0

To check the kernel version on AIX
ls -al /unix,

which_fileset /usr/lib/boot/unix_64,
lslpp -h bos.mp64

Print a \dump" of system information
prtconf

To View Only Configuration File Directives ( uncommented lines of a config file )
grep -v "^#" /path/to/config/file
(or)
sed '/ *#/d; /^ *$/d' /path/to/file

To find UNIX / Linux command for particular task
apropos -r 'remove file'

To Linux Find Out Virtual Memory PAGESIZE
getconf PAGESIZE

To Identify the Firmware level
lsmcode,
lsmcode -A,
lsmcode -d fcs0

Determining the program that caused the core dump
strings corefilename |grep _=
(or)
lquerypv -h corefilename 6b0 64

No comments:

Post a Comment