AIX Devices

List all devices on a system
lsdev

List all disk devices on a system (Some other devices are: adapter,driver, logical volume, processor)
lsdev -Cc disk

To verify the processor capacity
prtconf -c (64bit/32bit)

List all customized (existing) device classes (-P for complete list)
lsdev -C -r class

Remove hdisk5
rmdev -dl hdisk5

Get device address of hdisk1
getconf DISK DEVNAME hdisk1 or bootinfo -o hdisk1

Get the size (in MB) of hdisk1
getconf DISK SIZE hdisk1 or bootinfo -s hdisk1

Find the slot of a PCI Ethernet adapter
lsslot -c pci -l ent0

Find the (virtual) location of an Ethernet adapter
lscfg -l ent1

Find the location codes of all devices in the system
lscfg

List all MPIO paths for hdisk0
lspath -l hdisk0

Find the WWN of the fcs0 HBA adapter
lscfg -vl fcs0 |grep Network

Temporarily change console output to /console.out
swcons /console.out (Use swcons to change back.)

To Identify the Parent Device
lsdev -Cc disk -l hdisk1 -F parent

To Identify the Predefined Device Line number
lsdev -Cc disk -l hdisk28 -F PdDvLn

To Check the device status
lsdev -Cc disk -l hdisk1 -S A -F status

To get information about dar1 devices
odmget -q 'name = dar1 AND attribute = all_controller' CuAt
odmget -q 'PdDvLn = disk/fdar/array' HACMPdisktype
odmget -q 'name = hdisk7 AND PdDvLn = disk/fdar/array' CuDv

To Remove Devices
rmdev -l fcs1 (or) rmdev -l fcs1 -R (along with all the child devices)

Command to extract snap.pax.z
zcat ../snap.pax.Z |pax -rf -

To Check no of processors on the system
lscfg |grep proc

To know the parent devices
server1: lsdev -Cl hdisk0 -F parent
scsi0
server1: lsdev -Cl scsi0 -F parent
pci12
server1: lsdev -Cl pci12 -F parent
pci3
server1: lsdev -Cl pci3 -F parent
sysplanar0

To lists devices owned by an adapter
lsdev -p scsi0

No comments:

Post a Comment