Power Saver Mode


Power Save Mode:

hscroot_10@hmc122:~> lspwrmgmt -m sys506 -r sys
name=sys506,type_model=8233-E8B,serial_num=0681C1R,curr_power_saver_mode=Disabled,desired_power_saver_mode=Disabled

hscroot_10@hmc122:~> chpwrmgmt -m sys506 -r sys -o enable

hscroot_10@hmc122:~>
hscroot_10@hmc122:~> lspwrmgmt -m sys506 -r sys
name=sys506,type_model=8233-E8B,serial_num=0681C1R,curr_power_saver_mode=Enabled,desired_power_saver_mode=Enabled

PowerVM - Creating file-backed virtual disk


Creating file-backed virtual disk

$ lspv -> To list the disks
$ echo bootinfo -s hdisk1 |oem_setup_env -> To know the disk size
$ mksp -f mohisp hdisk1 -> To create a new logical volume storage pool
mohisp
0516-1254 mkvg: Changing the PVID in the ODM.
$
After creating lv storage pool, view the output of lspv to verify hdisk1 is in the mohisp volume group
$ lspv
NAME             PVID                                 VG               STATUS
hdisk0           00f78197033419c9                     rootvg           active
hdisk1           00f7819729165173                     mohisp           active
hdisk2           none                                 None
hdisk3           00f781971f83c6a6                     None
hdisk4           00edece71f375577                     None
hdisk5           none                                 None
hdisk6           none                                 None
hdisk7           none                                 None
$

$ lssp  à To verify the mohisp storage pool
Pool              Size(mb)   Free(mb)  Alloc Size(mb)    BDs Type
rootvg               30656      17920              64      0 LVPOOL
mohisp               10168      10168               8      0 LVPOOL
$

Now create the file-backed disk storage pool inside the mohisp storage pool. Name it fbpool and make it 1GB
$ mksp -fb fbpool -sp mohisp -size 1G
fbpool
File system created successfully.
1040148 kilobytes total disk space.
New File System size is 2097152
$

Now create the file-backed disk device in fbpool disk storage pool. Make the file 500MB in size and associate it with the VSCSI server adapter defined on the VIO server. When we run the command to create the disk device, note the new virtual target device name.

$ mkbdsp -sp fbpool 500m -bd fb_disk01 -vadapter vhost0
Creating file "fb_disk01" in storage pool "fbpool".
Assigning file "fb_disk01" as a backing device.
vtscsi1 Available
fb_disk01
$

Now view the lsmap output for vhost0 to verify the configuration. We can see that new virtual target device and it’s associating backing device
$ lsmap -vadapter vhost0
SVSA            Physloc                                      Client Partition ID
--------------- -------------------------------------------- ------------------
vhost0          U8233.E8B.068197R-V4-C4                      0x00000006

VTD                   vtscsi0
Status                Available
LUN                   0x8100000000000000
Backing device        hdisk3
Physloc               U5877.001.9K8D297-P1-C8-T1-W500507680110D43B-L3000000000000
Mirrored              false

VTD                   vtscsi1
Status                Available
LUN                   0x8200000000000000
Backing device        /var/vio/storagepools/fbpool/fb_disk01
Physloc
Mirrored              N/A

$

Also run “lsdev –virtual” output and see the description for the new virtual target device

$ lsdev -virtual
name             status      description
ent2             Available   Virtual I/O Ethernet Adapter (l-lan)
ent3             Available   Virtual I/O Ethernet Adapter (l-lan)
vasi0            Available   Virtual Asynchronous Services Interface (VASI)
vbsd0            Available   Virtual Block Storage Device (VBSD)
vfchost0         Available   Virtual FC Server Adapter
vhost0           Available   Virtual SCSI Server Adapter
vsa0             Available   LPAR Virtual Serial Adapter
name             status      description
vtscsi0          Available   Virtual Target Device - Disk
vtscsi1          Available   Virtual Target Device - File-backed Disk
name             status      description
ent4             Available   Shared Ethernet Adapter
$

PowerVM - Backup the virtual and logical configurations


VIO – Backup the virtual and logical configurations

$ viosbr –backup –file vio3-backup -> To backup all the device attributes as well as logical virtual device mapping on the VIO server
Backup of this node (vio3) successful
$ viosbr –view –list -> To list the content of the backup file
$ viosbr –view –file vio3-backup.tar.gz -> To display the content of the backup file

PowerVM Commands - Part2

$ ioslevel  -> To know the ios level
$ cfgdev  -> to scan and configure the new virtual devices
$ lsdev  à To check the new devices
$ lsdev –type adapter  -> To list all type adapters on VIO
$ lsdev –virtual -> To list only virtual adapter devices
$ lsdev –dev vfchost* -> To list virtual FC adapters on VIO
$ lsdev –dev fcs* -> To list physical FC adapters available on VIO
$ lsdev –slots -> To list the adapter slots
$ cfgassist  -> Config wizard for hostname, tcp/ip in VIO
$ lsmap –all -> To show the mapping details on VIO
$ lspv à To list all disks on VIO
$ lspv –free à To list only free disks
$ mirrorios -> To mirror the VIO’s rootvg
$ backupios -> To backup the ioserver
$ installios -> To install new version of ioserver
$ updateios  -> To update the ios new version
$ mkrep -> To create virtual media repository
$ lsdev –dev hdisk3 –attr |grep reserve_policy -> To check hdisk reserve policy attribute
$ chdev –dev hdisk3 attr reserve_policy=no_reserve -> To change the hdisk reserve policy to no_reserve
$ mkvdev –vdev hdisk3 –vadapter vhost0 –dev lpar1_vdisk1 -> To create the virtual target device
$ lsmap –vadapter vhost0 -> To check we have correct backing storage mapping
$ shutdown à To shutdown the VIO server
$ shutdown –restart -> To reboot the VIO server.

PowerVM - Fix pack update


This example will shows the procedure to update the VIO server's fix pack,

$ ioslevel -> To see the current version
2.1.0.1-FP-20.0
$ oem_setup_env
# emgr –P  -> To list the interim fixes
# emgr –r –L -> To remove the interim fixes
$ updateios -commit
There are no uncommitted updates.

mount nfs_server:/export/ VIO_2.2.1.1.FP25 /mnt
updateios -dev /mnt/VIO_2.2.1.1.FP25 -install -accept

$ shutdown –restart -> To reboot the VIO server -> Reboot VIO after upgrade
$ license –accept -> After upgrading we have to accept the license
$ ioslevel -> VIO server version got changed after upgrade and reboot
2.2.1.1